const regex = /^yellow_y\s+\K\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^yellow_y\\s+\\K\\S+', 'gm')
const str = `yellow abc \\
yellow_x abc \\
yellow_y acc \\
blue abb \\
pink abb \\
pink_xx acd \\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}