using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^yellow_y\s+\K\S+";
string input = @"yellow abc \
yellow_x abc \
yellow_y acc \
blue abb \
pink abb \
pink_xx acd \";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}