$re = '/^yellow_y\s+\K\S+/m';
$str = 'yellow abc \\
yellow_x abc \\
yellow_y acc \\
blue abb \\
pink abb \\
pink_xx acd \\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);