using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<code(?:\s+type=(?:""([^""]+)""|\'([^\']+)|(\w+)))?>(.*?)<\/code>";
string input = @"Hallo das sind Code Tags: <code>das ist ein code tag</code> oder das <code type=""php"">echo ""Hallo Welt!"";</code> oder <code type=html> <h1>Willkommen!</h1> </code>. Danke.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}