package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<code(?:\s+type=(?:"([^"]+)"|\'([^\']+)|(\w+)))?>(.*?)<\/code>`)
var str = `Hallo das sind Code Tags: <code>das ist ein code tag</code> oder das <code type="php">echo "Hallo Welt!";</code> oder <code type=html> <h1>Willkommen!</h1> </code>. Danke.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}