$re = '~<code(?:\s+type=(?:"([^"]+)"|\'([^\']+)|(\w+)))?>(.*?)<\/code>~is';
$str = 'Hallo das sind Code Tags: <code>das ist ein code tag</code> oder das <code type="php">echo "Hallo Welt!";</code> oder <code type=html> <h1>Willkommen!</h1> </code>. Danke.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);