const regex = new RegExp('<code(?:\\s+type=(?:"([^"]+)"|\\\\'([^\\\\']+)|(\\w+)))?>(.*?)<\\/code>', 'isg')
const str = `Hallo das sind Code Tags: <code>das ist ein code tag</code> oder das <code type="php">echo "Hallo Welt!";</code> oder <code type=html> <h1>Willkommen!</h1> </code>. Danke.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}