// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<code(?:\s+type=(?:"([^"]+)"|\'([^\']+)|(\w+)))?>(.*?)<\/code>"#).unwrap();
let string = "Hallo das sind Code Tags: <code>das ist ein code tag</code> oder das <code type=\"php\">echo \"Hallo Welt!\";</code> oder <code type=html> <h1>Willkommen!</h1> </code>. Danke.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}