#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d*\/\d*\/\d*, \d*:\d* - (?!\:)"
Local $sString = "3/9/18, 17:47 - Pessoa 1: Oi gente!" & @CRLF & _
"3/10/18, 22:59 - Pessoa 2 entrou no grupo." & @CRLF & _
"3/10/18, 09:35 - Pessoa 2: Salve!" & @CRLF & _
"O que tá rolando de bom?" & @CRLF & _
"3/10/18, 09:36 - Pessoa 1: Quanto tempo!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")