re = /\d*\/\d*\/\d*, \d*:\d* - (?!\:)/m
str = '3/9/18, 17:47 - Pessoa 1: Oi gente!
3/10/18, 22:59 - Pessoa 2 entrou no grupo.
3/10/18, 09:35 - Pessoa 2: Salve!
O que tá rolando de bom?
3/10/18, 09:36 - Pessoa 1: Quanto tempo!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end