const regex = /\d*\/\d*\/\d*, \d*:\d* - (?!\:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*\\\/\\d*\\\/\\d*, \\d*:\\d* - (?!\\:)', 'gm')
const str = `3/9/18, 17:47 - Pessoa 1: Oi gente!
3/10/18, 22:59 - Pessoa 2 entrou no grupo.
3/10/18, 09:35 - Pessoa 2: Salve!
O que tá rolando de bom?
3/10/18, 09:36 - Pessoa 1: Quanto tempo!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}