import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*\\/\\d*\\/\\d*, \\d*:\\d* - (?!\\:)";
final String string = "3/9/18, 17:47 - Pessoa 1: Oi gente!\n"
+ "3/10/18, 22:59 - Pessoa 2 entrou no grupo.\n"
+ "3/10/18, 09:35 - Pessoa 2: Salve!\n"
+ "O que tá rolando de bom?\n"
+ "3/10/18, 09:36 - Pessoa 1: Quanto tempo!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}