# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d*\/\d*\/\d*, \d*:\d* - (?!\:)"
test_str = ("3/9/18, 17:47 - Pessoa 1: Oi gente!\n"
"3/10/18, 22:59 - Pessoa 2 entrou no grupo.\n"
"3/10/18, 09:35 - Pessoa 2: Salve!\n"
"O que tá rolando de bom?\n"
"3/10/18, 09:36 - Pessoa 1: Quanto tempo!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.