use strict;
my $str = '3/9/18, 17:47 - Pessoa 1: Oi gente!
3/10/18, 22:59 - Pessoa 2 entrou no grupo.
3/10/18, 09:35 - Pessoa 2: Salve!
O que tá rolando de bom?
3/10/18, 09:36 - Pessoa 1: Quanto tempo!';
my $regex = qr/\d*\/\d*\/\d*, \d*:\d* - (?!\:)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}