const regex = /(\(|\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\)|\]| |-|$)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(|\\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\\)|\\]| |-|$)+', 'g')
const str = `Antivirus, Booster & Cleaner - Android - US
Monster Strike Android JP
LINE Bubble 2 iOS (JP)
LINE Bubble 2 iOS ( JP , AU )
Monster Strike (iPhone, iPad) JP
Game of War Android (US AU CA JP KR GB)
Caesars Slots iPhone ( AU,CA, NZ,US)
Caesars Slots iPhone [ AU,CA, NZ,US]
Caesars Slots iPhone AU,CA, NZ,US
( ,AU) Caesars Slots iPhone
match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}