// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\(|\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\)|\]| |-|$)+").unwrap();
let string = "Antivirus, Booster & Cleaner - Android - US
Monster Strike Android JP
LINE Bubble 2 iOS (JP)
LINE Bubble 2 iOS ( JP , AU )
Monster Strike (iPhone, iPad) JP
Game of War Android (US AU CA JP KR GB)
Caesars Slots iPhone ( AU,CA, NZ,US)
Caesars Slots iPhone [ AU,CA, NZ,US]
Caesars Slots iPhone AU,CA, NZ,US
( ,AU) Caesars Slots iPhone
match";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}