import re
regex = re.compile(r"(\(|\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\)|\]| |-|$)+")
test_str = ("Antivirus, Booster & Cleaner - Android - US\n"
"Monster Strike Android JP\n"
"LINE Bubble 2 iOS (JP)\n"
"LINE Bubble 2 iOS ( JP , AU )\n"
"Monster Strike (iPhone, iPad) JP\n"
"Game of War Android (US AU CA JP KR GB)\n"
"Caesars Slots iPhone ( AU,CA, NZ,US)\n"
"Caesars Slots iPhone [ AU,CA, NZ,US]\n"
"Caesars Slots iPhone AU,CA, NZ,US\n"
"( ,AU) Caesars Slots iPhone\n"
" match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")