use strict;
my $str = 'Antivirus, Booster & Cleaner - Android - US
Monster Strike Android JP
LINE Bubble 2 iOS (JP)
LINE Bubble 2 iOS ( JP , AU )
Monster Strike (iPhone, iPad) JP
Game of War Android (US AU CA JP KR GB)
Caesars Slots iPhone ( AU,CA, NZ,US)
Caesars Slots iPhone [ AU,CA, NZ,US]
Caesars Slots iPhone AU,CA, NZ,US
( ,AU) Caesars Slots iPhone
match';
my $regex = qr/(\(|\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\)|\]| |-|$)+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}