$re = '/(\(|\[| |-)+((,| )*(AU|JP|CA|NZ|US|KR|GB)(,| )*)+(\)|\]| |-|$)+/';
$str = 'Antivirus, Booster & Cleaner - Android - US
Monster Strike Android JP
LINE Bubble 2 iOS (JP)
LINE Bubble 2 iOS ( JP , AU )
Monster Strike (iPhone, iPad) JP
Game of War Android (US AU CA JP KR GB)
Caesars Slots iPhone ( AU,CA, NZ,US)
Caesars Slots iPhone [ AU,CA, NZ,US]
Caesars Slots iPhone AU,CA, NZ,US
( ,AU) Caesars Slots iPhone
match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);