#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*?\/form\/).*\.txt$"
Local $sString = "Should match:" & @CRLF & _
"/vol/form.txt" & @CRLF & _
"/a/b/c/d/form.txt" & @CRLF & _
"/vol/var/hello.txt" & @CRLF & _
"./f.txt" & @CRLF & _
"./x/x.txt" & @CRLF & _
"/tmp/test/f.txt" & @CRLF & _
"/tmp/test/x/x.txt" & @CRLF & _
"" & @CRLF & _
"Should NOT match:" & @CRLF & _
"/vol/form/various.txt" & @CRLF & _
"/form/athrird.txt" & @CRLF & _
"/a/b/c/d/form/forth.txt" & @CRLF & _
"/vol/var/sender.py" & @CRLF & _
"./form" & @CRLF & _
"./form/xxx.txt" & @CRLF & _
"./x" & @CRLF & _
"/tmp/test/form/xxx.txt" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")