import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?\\/form\\/).*\\.txt$";
final String string = "Should match:\n"
+ "/vol/form.txt\n"
+ "/a/b/c/d/form.txt\n"
+ "/vol/var/hello.txt\n"
+ "./f.txt\n"
+ "./x/x.txt\n"
+ "/tmp/test/f.txt\n"
+ "/tmp/test/x/x.txt\n\n"
+ "Should NOT match:\n"
+ "/vol/form/various.txt\n"
+ "/form/athrird.txt\n"
+ "/a/b/c/d/form/forth.txt\n"
+ "/vol/var/sender.py\n"
+ "./form\n"
+ "./form/xxx.txt\n"
+ "./x\n"
+ "/tmp/test/form/xxx.txt\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}