import Foundation
let pattern = #"^(?!.*?\/form\/).*\.txt$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should match:
/vol/form.txt
/a/b/c/d/form.txt
/vol/var/hello.txt
./f.txt
./x/x.txt
/tmp/test/f.txt
/tmp/test/x/x.txt
Should NOT match:
/vol/form/various.txt
/form/athrird.txt
/a/b/c/d/form/forth.txt
/vol/var/sender.py
./form
./form/xxx.txt
./x
/tmp/test/form/xxx.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)