use strict;
my $str = 'Should match:
/vol/form.txt
/a/b/c/d/form.txt
/vol/var/hello.txt
./f.txt
./x/x.txt
/tmp/test/f.txt
/tmp/test/x/x.txt
Should NOT match:
/vol/form/various.txt
/form/athrird.txt
/a/b/c/d/form/forth.txt
/vol/var/sender.py
./form
./form/xxx.txt
./x
/tmp/test/form/xxx.txt
';
my $regex = qr/^(?!.*?\/form\/).*\.txt$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}