# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*?\/form\/).*\.txt$"
test_str = ("Should match:\n"
"/vol/form.txt\n"
"/a/b/c/d/form.txt\n"
"/vol/var/hello.txt\n"
"./f.txt\n"
"./x/x.txt\n"
"/tmp/test/f.txt\n"
"/tmp/test/x/x.txt\n\n"
"Should NOT match:\n"
"/vol/form/various.txt\n"
"/form/athrird.txt\n"
"/a/b/c/d/form/forth.txt\n"
"/vol/var/sender.py\n"
"./form\n"
"./form/xxx.txt\n"
"./x\n"
"/tmp/test/form/xxx.txt\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.