$re = '/^(?!.*?\/form\/).*\.txt$/m';
$str = 'Should match:
/vol/form.txt
/a/b/c/d/form.txt
/vol/var/hello.txt
./f.txt
./x/x.txt
/tmp/test/f.txt
/tmp/test/x/x.txt
Should NOT match:
/vol/form/various.txt
/form/athrird.txt
/a/b/c/d/form/forth.txt
/vol/var/sender.py
./form
./form/xxx.txt
./x
/tmp/test/form/xxx.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);