#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\D(\d)$"
Local $sString = "Paris 3" & @CRLF & _
"Paris 17" & @CRLF & _
"Marseille 5" & @CRLF & _
"Abainville" & @CRLF & _
"Aast" & @CRLF & _
"Marseille 15" & @CRLF & _
"Lyon 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")