const regex = /\D(\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D(\\d)$', 'gm')
const str = `Paris 3
Paris 17
Marseille 5
Abainville
Aast
Marseille 15
Lyon 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}