re = /\D(\d)$/m
str = 'Paris 3
Paris 17
Marseille 5
Abainville
Aast
Marseille 15
Lyon 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end