import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\D(\\d)$";
final String string = "Paris 3\n"
+ "Paris 17\n"
+ "Marseille 5\n"
+ "Abainville\n"
+ "Aast\n"
+ "Marseille 15\n"
+ "Lyon 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}