package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\D(\d)$`)
var str = `Paris 3
Paris 17
Marseille 5
Abainville
Aast
Marseille 15
Lyon 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}