const regex = /^(.|\n){240,}$()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.|\\n){240,}$()', 'gm')
const str = `12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
123456789012345678901234567890123456`;
const subst = `$2(\$2)is for replace all text with nothing (remoove all text)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);