$re = '/^(.|\n){240,}$()/m';
$str = '12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
123456789012345678901234567890123456';
$subst = "$2(\$2)is for replace all text with nothing (remoove all text)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;