// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.|\n){240,}$()").unwrap();
let string = "12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
123456789012345678901234567890123456";
let substitution = "$2(\\$2)is for replace all text with nothing (remoove all text)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}