use strict;
my $str = '12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
123456789012345678901234567890123456';
my $regex = qr/^(.|\n){240,}$()/mp;
my $subst = '$2(\\$2)is for replace all text with nothing (remoove all text)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";