re = /^(.|\n){240,}$()/m
str = '12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890
123456789012345678901234567890123456'
subst = '$2(\\$2)is for replace all text with nothing (remoove all text)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result