using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+\[?(.+?)\]?";
string input = @"Application key [base64:HlOiabVcCmzUvcnPuCHCOS6nvS89otzCBXKb/PVbI1g=] set successfully.
base64:zI1EaQeidtfpLwE9b8sGo5sZDbnzAqULCnL2hT3HoJo=";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}