re = /.+\[?(.+?)\]?/i
str = 'Application key [base64:HlOiabVcCmzUvcnPuCHCOS6nvS89otzCBXKb/PVbI1g=] set successfully.
base64:zI1EaQeidtfpLwE9b8sGo5sZDbnzAqULCnL2hT3HoJo='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end