import re
regex = re.compile(r".+\[?(.+?)\]?", flags=re.IGNORECASE)
test_str = ("Application key [base64:HlOiabVcCmzUvcnPuCHCOS6nvS89otzCBXKb/PVbI1g=] set successfully.\n\n"
"base64:zI1EaQeidtfpLwE9b8sGo5sZDbnzAqULCnL2hT3HoJo=")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")