const regex = /.+\[?(.+?)\]?/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+\\[?(.+?)\\]?', 'ig')
const str = `Application key [base64:HlOiabVcCmzUvcnPuCHCOS6nvS89otzCBXKb/PVbI1g=] set successfully.
base64:zI1EaQeidtfpLwE9b8sGo5sZDbnzAqULCnL2hT3HoJo=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}