#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[<"'](\S+)[">']"
Local $sString = "... fatal error: Foobar.h: No such file or directory" & @CRLF & _
" #include <Foobar.h>" & @CRLF & _
"" & @CRLF & _
"test.c:2:10: fatal error: 'file.h' file not found" & @CRLF & _
" 2 | #include <file.h>" & @CRLF & _
" | ^~~~~~~~" & @CRLF & _
"1 error generated." & @CRLF & _
"" & @CRLF & _
"... fatal error: Foobar.h: No such file or directory" & @CRLF & _
" 2 | #include <Foobar.h>" & @CRLF & _
"" & @CRLF & _
"... fatal error: Foobar.h: No such file or directory" & @CRLF & _
" 2 | #include <Foobar.h>" & @CRLF & _
"" & @CRLF & _
"test.c:3:4: error: expected identifier or '('" & @CRLF & _
" 3 | an "unrelated" error" & @CRLF & _
" | ^" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")