using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[<""'](\S+)["">']";
string input = @"... fatal error: Foobar.h: No such file or directory
#include <Foobar.h>
test.c:2:10: fatal error: 'file.h' file not found
2 | #include <file.h>
| ^~~~~~~~
1 error generated.
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
test.c:3:4: error: expected identifier or '('
3 | an ""unrelated"" error
| ^
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}