# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[<\"'](\S+)[\">']"
test_str = ("... fatal error: Foobar.h: No such file or directory\n"
" #include <Foobar.h>\n\n"
"test.c:2:10: fatal error: 'file.h' file not found\n"
" 2 | #include <file.h>\n"
" | ^~~~~~~~\n"
"1 error generated.\n\n"
"... fatal error: Foobar.h: No such file or directory\n"
" 2 | #include <Foobar.h>\n\n"
"... fatal error: Foobar.h: No such file or directory\n"
" 2 | #include <Foobar.h>\n\n"
"test.c:3:4: error: expected identifier or '('\n"
" 3 | an \"unrelated\" error\n"
" | ^\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.