const regex = /[<"'](\S+)[">']/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[<"\'](\\S+)[">\']', 'gm')
const str = `... fatal error: Foobar.h: No such file or directory
#include <Foobar.h>
test.c:2:10: fatal error: 'file.h' file not found
2 | #include <file.h>
| ^~~~~~~~
1 error generated.
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
test.c:3:4: error: expected identifier or '('
3 | an "unrelated" error
| ^
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}