use strict;
my $str = '... fatal error: Foobar.h: No such file or directory
#include <Foobar.h>
test.c:2:10: fatal error: \'file.h\' file not found
2 | #include <file.h>
| ^~~~~~~~
1 error generated.
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
test.c:3:4: error: expected identifier or \'(\'
3 | an "unrelated" error
| ^
';
my $regex = qr/[<"'](\S+)[">']/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}