import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[<\"'](\\S+)[\">']";
final String string = "... fatal error: Foobar.h: No such file or directory\n"
+ " #include <Foobar.h>\n\n"
+ "test.c:2:10: fatal error: 'file.h' file not found\n"
+ " 2 | #include <file.h>\n"
+ " | ^~~~~~~~\n"
+ "1 error generated.\n\n"
+ "... fatal error: Foobar.h: No such file or directory\n"
+ " 2 | #include <Foobar.h>\n\n"
+ "... fatal error: Foobar.h: No such file or directory\n"
+ " 2 | #include <Foobar.h>\n\n"
+ "test.c:3:4: error: expected identifier or '('\n"
+ " 3 | an \"unrelated\" error\n"
+ " | ^\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}