# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<token>"[^"]+"\s*:\s*)(?:\d*[^\d:][^:]*:)*(?<number>\d+)(?::[^:]*)*$/$1$2/;t' <<< "\"number\":4aac4c35-8e3e-4730-8364-381884d6f20f:DA:OPAS:117804471:PAN:false"