import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<token>\"[^\"]+\"\\s*:\\s*)(?:\\d*[^\\d:][^:]*:)*(?<number>\\d+)(?::[^:]*)*$";
final String string = "\"number\":4aac4c35-8e3e-4730-8364-381884d6f20f:DA:OPAS:117804471:PAN:false";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}