$re = '/^(?<token>"[^"]+"\s*:\s*)(?:\d*[^\d:][^:]*:)*(?<number>\d+)(?::[^:]*)*$/';
$str = '"number":4aac4c35-8e3e-4730-8364-381884d6f20f:DA:OPAS:117804471:PAN:false';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;