use strict;
my $str = '"number":4aac4c35-8e3e-4730-8364-381884d6f20f:DA:OPAS:117804471:PAN:false';
my $regex = qr/^(?<token>"[^"]+"\s*:\s*)(?:\d*[^\d:][^:]*:)*(?<number>\d+)(?::[^:]*)*$/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";