// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(?<token>"[^"]+"\s*:\s*)(?:\d*[^\d:][^:]*:)*(?<number>\d+)(?::[^:]*)*$"#).unwrap();
let string = "\"number\":4aac4c35-8e3e-4730-8364-381884d6f20f:DA:OPAS:117804471:PAN:false";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}